package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^body|\sbody([\s*|\{|:])`)
var str = `body .myclass{
font: heavy;
}
body#p-5 #main .box h2 {
font-size: 21.85px
}
body.myclass .hello {
font-size: 10px;
}
body .myclass{
font: heavy;
}
body#p-5 #main .box h2 {
font-size: 21.85px
}
body.myclass .hello {
font-size: 10px;
}
body .myclass {
font: heavy;
}
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}