import Foundation
let pattern = #"^body|\sbody([\s*|\{|:])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
body .myclass{
font: heavy;
}
body#p-5 #main .box h2 {
font-size: 21.85px
}
body.myclass .hello {
font-size: 10px;
}
body .myclass{
font: heavy;
}
body#p-5 #main .box h2 {
font-size: 21.85px
}
body.myclass .hello {
font-size: 10px;
}
body .myclass {
font: heavy;
}
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)