#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "loc=[A-Z][0-9]{2}:[0-9]{2}:[0-9]{2}:[0-9]{2}"
Local $sString = "http://epsilon.astroempires.com/map.aspx?loc=E23:36:03:20"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")