import Foundation
let pattern = #"loc=[A-Z][0-9]{2}:[0-9]{2}:[0-9]{2}:[0-9]{2}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"http://epsilon.astroempires.com/map.aspx?loc=E23:36:03:20"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}