re = /loc=[A-Z][0-9]{2}:[0-9]{2}:[0-9]{2}:[0-9]{2}/
str = 'http://epsilon.astroempires.com/map.aspx?loc=E23:36:03:20'
# Print the match result
str.match(re) do |match|
puts match.to_s
end