package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`loc=[A-Z][0-9]{2}:[0-9]{2}:[0-9]{2}:[0-9]{2}`)
var str = `http://epsilon.astroempires.com/map.aspx?loc=E23:36:03:20`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}