const regex = /loc=[A-Z][0-9]{2}:[0-9]{2}:[0-9]{2}:[0-9]{2}/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('loc=[A-Z][0-9]{2}:[0-9]{2}:[0-9]{2}:[0-9]{2}', '')
const str = `http://epsilon.astroempires.com/map.aspx?loc=E23:36:03:20`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}