using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"loc=[A-Z][0-9]{2}:[0-9]{2}:[0-9]{2}:[0-9]{2}";
string input = @"http://epsilon.astroempires.com/map.aspx?loc=E23:36:03:20";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}