// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"loc=[A-Z][0-9]{2}:[0-9]{2}:[0-9]{2}:[0-9]{2}").unwrap();
let string = "http://epsilon.astroempires.com/map.aspx?loc=E23:36:03:20";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}