package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((25[0-5]|2[0-4][0-9]|[01]?[0-9]{1,2})\.){3}(?2)$`)
var str = `300.300.200.100
12.54.255.254
55.19.16.56.
55.19.01.1
12.54.56.56`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}