re = /^((25[0-5]|2[0-4][0-9]|[01]?[0-9]{1,2})\.){3}(?2)$/m
str = '300.300.200.100
12.54.255.254
55.19.16.56.
55.19.01.1
12.54.56.56'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end