// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^((25[0-5]|2[0-4][0-9]|[01]?[0-9]{1,2})\.){3}(?2)$").unwrap();
let string = "300.300.200.100
12.54.255.254
55.19.16.56.
55.19.01.1
12.54.56.56";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}