use strict;
my $str = '300.300.200.100
12.54.255.254
55.19.16.56.
55.19.01.1
12.54.56.56';
my $regex = qr/^((25[0-5]|2[0-4][0-9]|[01]?[0-9]{1,2})\.){3}(?2)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}