import re
regex = re.compile(r"^((25[0-5]|2[0-4][0-9]|[01]?[0-9]{1,2})\.){3}(?2)$", flags=re.MULTILINE)
test_str = ("300.300.200.100\n"
"12.54.255.254\n"
"55.19.16.56.\n"
"55.19.01.1\n"
"12.54.56.56")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")