import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((25[0-5]|2[0-4][0-9]|[01]?[0-9]{1,2})\\.){3}(?2)$";
final String string = "300.300.200.100\n"
+ "12.54.255.254\n"
+ "55.19.16.56.\n"
+ "55.19.01.1\n"
+ "12.54.56.56";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}