using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^\[//\]:[^(]+\(\K
|
\G(?!\A)\|
)
(\w+):([\w,]+)";
string input = @"[//]: # (POST:28|USERS:102,78,90)
some other markdown here
### as well as here ###";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}