$re = '~(?:^\[//\]:[^(]+\(\K
|
\G(?!\A)\|
)
(\w+):([\w,]+)~mx';
$str = '[//]: # (POST:28|USERS:102,78,90)
some other markdown here
### as well as here ###';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);