const regex = new RegExp('(?:^\\[//\\]:[^(]+\\(\\K
|
\\G(?!\\A)\\|
)
(\\w+):([\\w,]+)', 'gm')
const str = `[//]: # (POST:28|USERS:102,78,90)
some other markdown here
### as well as here ###`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}