import re
regex = re.compile(r"""
(?:^\[//\]:[^(]+\(\K
|
\G(?!\A)\|
)
(\w+):([\w,]+)
""", flags=re.MULTILINE | re.VERBOSE)
test_str = ("[//]: # (POST:28|USERS:102,78,90)\n"
"some other markdown here\n"
"### as well as here ###")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")