re = /(?:^\[\/\/\]:[^(]+\(\K
|
\G(?!\A)\|
)
(\w+):([\w,]+)/mx
str = '[//]: # (POST:28|USERS:102,78,90)
some other markdown here
### as well as here ###'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end