#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^(.*?).([a-z]+)\[([0-9]+)|:([0-9]+)]"
Local $sString = "Server: firesideweb01:8002" & @CRLF & _
"Uptime: 10:56:19" & @CRLF & _
"" & @CRLF & _
"=== Address Service ===" & @CRLF & _
"Build Number : 2381" & @CRLF & _
"Database Date : 2015-07-15" & @CRLF & _
"Database Expiration Date: 10-31-2015" & @CRLF & _
"License Expiration Date : 2016-05-03" & @CRLF & _
"" & @CRLF & _
"Validate Calls: 395224" & @CRLF & _
" Valid : 178993" & @CRLF & _
" Invalid : 216231" & @CRLF & _
"Format" & @CRLF & _
" Short : 358570" & @CRLF & _
" Long : 36654" & @CRLF & _
" Auto : 0" & @CRLF & _
"" & @CRLF & _
"=== Name Service ===" & @CRLF & _
"Build Number : 2381" & @CRLF & _
"Database Date : 2015-06-15" & @CRLF & _
"Database Expiration Date: 2015-12-15" & @CRLF & _
"License Expiration Date : 2016-05-03" & @CRLF & _
"" & @CRLF & _
"Normalize Calls: 0" & @CRLF & _
"IsMatch Calls : 0"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")