import Foundation
let pattern = #"^(.*?).([a-z]+)\[([0-9]+)|:([0-9]+)]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Server: firesideweb01:8002
Uptime: 10:56:19
=== Address Service ===
Build Number : 2381
Database Date : 2015-07-15
Database Expiration Date: 10-31-2015
License Expiration Date : 2016-05-03
Validate Calls: 395224
Valid : 178993
Invalid : 216231
Format
Short : 358570
Long : 36654
Auto : 0
=== Name Service ===
Build Number : 2381
Database Date : 2015-06-15
Database Expiration Date: 2015-12-15
License Expiration Date : 2016-05-03
Normalize Calls: 0
IsMatch Calls : 0
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)