using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.*?).([a-z]+)\[([0-9]+)|:([0-9]+)]";
string input = @"Server: firesideweb01:8002
Uptime: 10:56:19
=== Address Service ===
Build Number : 2381
Database Date : 2015-07-15
Database Expiration Date: 10-31-2015
License Expiration Date : 2016-05-03
Validate Calls: 395224
Valid : 178993
Invalid : 216231
Format
Short : 358570
Long : 36654
Auto : 0
=== Name Service ===
Build Number : 2381
Database Date : 2015-06-15
Database Expiration Date: 2015-12-15
License Expiration Date : 2016-05-03
Normalize Calls: 0
IsMatch Calls : 0";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}