const regex = /^(.*?).([a-z]+)\[([0-9]+)|:([0-9]+)]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*?).([a-z]+)\\[([0-9]+)|:([0-9]+)]', 'g')
const str = `Server: firesideweb01:8002
Uptime: 10:56:19
=== Address Service ===
Build Number : 2381
Database Date : 2015-07-15
Database Expiration Date: 10-31-2015
License Expiration Date : 2016-05-03
Validate Calls: 395224
Valid : 178993
Invalid : 216231
Format
Short : 358570
Long : 36654
Auto : 0
=== Name Service ===
Build Number : 2381
Database Date : 2015-06-15
Database Expiration Date: 2015-12-15
License Expiration Date : 2016-05-03
Normalize Calls: 0
IsMatch Calls : 0`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}