use strict;
my $str = 'Server: firesideweb01:8002
Uptime: 10:56:19
=== Address Service ===
Build Number : 2381
Database Date : 2015-07-15
Database Expiration Date: 10-31-2015
License Expiration Date : 2016-05-03
Validate Calls: 395224
Valid : 178993
Invalid : 216231
Format
Short : 358570
Long : 36654
Auto : 0
=== Name Service ===
Build Number : 2381
Database Date : 2015-06-15
Database Expiration Date: 2015-12-15
License Expiration Date : 2016-05-03
Normalize Calls: 0
IsMatch Calls : 0';
my $regex = qr/^(.*?).([a-z]+)\[([0-9]+)|:([0-9]+)]/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}