import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.*?).([a-z]+)\\[([0-9]+)|:([0-9]+)]";
final String string = "Server: firesideweb01:8002\n"
+ "Uptime: 10:56:19\n\n"
+ "=== Address Service ===\n"
+ "Build Number : 2381\n"
+ "Database Date : 2015-07-15\n"
+ "Database Expiration Date: 10-31-2015\n"
+ "License Expiration Date : 2016-05-03\n\n"
+ "Validate Calls: 395224\n"
+ " Valid : 178993\n"
+ " Invalid : 216231\n"
+ "Format\n"
+ " Short : 358570\n"
+ " Long : 36654\n"
+ " Auto : 0\n\n"
+ "=== Name Service ===\n"
+ "Build Number : 2381\n"
+ "Database Date : 2015-06-15\n"
+ "Database Expiration Date: 2015-12-15\n"
+ "License Expiration Date : 2016-05-03\n\n"
+ "Normalize Calls: 0\n"
+ "IsMatch Calls : 0";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}