const regex = new RegExp('(\\S+)\\[(\\d+)/(\\d+)\\](?:\\s|$)', 'g')
const str = `Richard///[][][12345/678910111213141516] was murdered by Ralph[/[54321/161514131211109876]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}