# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/('[^']*'|[^',]*),\s*/\1\t/g;t' <<< "21, 2, '23.5R25 ETADT', 'description, with a comma'
22, 1, '26.5R25 ETADT', 'Description without a comma'
23, 5, '20.5R20.5', 'Another description with ; semicolumn'"