using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"('[^']*'|[^',]*),\s*";
string substitution = @"\1\t";
string input = @"21, 2, '23.5R25 ETADT', 'description, with a comma'
22, 1, '26.5R25 ETADT', 'Description without a comma'
23, 5, '20.5R20.5', 'Another description with ; semicolumn'";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}