# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"('[^']*'|[^',]*),\s*"
test_str = ("21, 2, '23.5R25 ETADT', 'description, with a comma'\n"
"22, 1, '26.5R25 ETADT', 'Description without a comma'\n"
"23, 5, '20.5R20.5', 'Another description with ; semicolumn'")
subst = "\\1\\t"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.