const regex = new RegExp('(\\'[^\\']*\\'|[^\\',]*),\\s*', 'g')
const str = `21, 2, '23.5R25 ETADT', 'description, with a comma'
22, 1, '26.5R25 ETADT', 'Description without a comma'
23, 5, '20.5R20.5', 'Another description with ; semicolumn'`;
const subst = `\1\t`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);