// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"('[^']*'|[^',]*),\s*").unwrap();
let string = "21, 2, '23.5R25 ETADT', 'description, with a comma'
22, 1, '26.5R25 ETADT', 'Description without a comma'
23, 5, '20.5R20.5', 'Another description with ; semicolumn'";
let substitution = "\\1\\t";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}