package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`('[^']*'|[^',]*),\s*`)
var str = `21, 2, '23.5R25 ETADT', 'description, with a comma'
22, 1, '26.5R25 ETADT', 'Description without a comma'
23, 5, '20.5R20.5', 'Another description with ; semicolumn'`
var substitution = "\1\t"
fmt.Println(re.ReplaceAllString(str, substitution))
}