import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "('[^']*'|[^',]*),\\s*";
final String string = "21, 2, '23.5R25 ETADT', 'description, with a comma'\n"
+ "22, 1, '26.5R25 ETADT', 'Description without a comma'\n"
+ "23, 5, '20.5R20.5', 'Another description with ; semicolumn'";
final String subst = "\\1\\t";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}