#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[A-Za-z](?:\s\d+|\s?\w+[,.-]+)*\s[^\s]+[.\s]*$"
Local $sString = "I fell down the stairs on June 30th, 1962." & @CRLF & _
"There are 123 boxes on up the hill, says that 612 guy." & @CRLF & _
"The lazy brown fox is not a dog." & @CRLF & _
"This sentence will work ." & @CRLF & _
"That one finally works... yay!" & @CRLF & _
"How do you spell-- regex?"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")