package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[A-Za-z](?:\s\d+|\s?\w+[,.-]+)*\s[^\s]+[.\s]*$`)
var str = `I fell down the stairs on June 30th, 1962.
There are 123 boxes on up the hill, says that 612 guy.
The lazy brown fox is not a dog.
This sentence will work .
That one finally works... yay!
How do you spell-- regex?`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}