// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[A-Za-z](?:\s\d+|\s?\w+[,.-]+)*\s[^\s]+[.\s]*$").unwrap();
let string = "I fell down the stairs on June 30th, 1962.
There are 123 boxes on up the hill, says that 612 guy.
The lazy brown fox is not a dog.
This sentence will work .
That one finally works... yay!
How do you spell-- regex?";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}