use strict;
my $str = 'I fell down the stairs on June 30th, 1962.
There are 123 boxes on up the hill, says that 612 guy.
The lazy brown fox is not a dog.
This sentence will work .
That one finally works... yay!
How do you spell-- regex?';
my $regex = qr/[A-Za-z](?:\s\d+|\s?\w+[,.-]+)*\s[^\s]+[.\s]*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}