import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[A-Za-z](?:\\s\\d+|\\s?\\w+[,.-]+)*\\s[^\\s]+[.\\s]*$";
final String string = "I fell down the stairs on June 30th, 1962.\n"
+ "There are 123 boxes on up the hill, says that 612 guy.\n"
+ "The lazy brown fox is not a dog.\n"
+ "This sentence will work .\n"
+ "That one finally works... yay!\n"
+ "How do you spell-- regex?";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}