re = /[A-Za-z](?:\s\d+|\s?\w+[,.-]+)*\s[^\s]+[.\s]*$/m
str = 'I fell down the stairs on June 30th, 1962.
There are 123 boxes on up the hill, says that 612 guy.
The lazy brown fox is not a dog.
This sentence will work .
That one finally works... yay!
How do you spell-- regex?'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end