#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=def.)\w+|\b((?!if)\w*(?!\s*[+])(?!.*==)(?=.*[=]))\b"
Local $sString = "a = 2" & @CRLF & _
"if a == 2:" & @CRLF & _
" b=3" & @CRLF & _
" a+=1" & @CRLF & _
"c = (a,b)" & @CRLF & _
"def d(x):" & @CRLF & _
" return x-1" & @CRLF & _
"a2,B_2 = (3,4)" & @CRLF & _
"(g, [h, i]) = [5,[6,7]] " & @CRLF & _
"(?![+])"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")