$re = '/(?<=def.)\w+|\b((?!if)\w*(?!\s*[+])(?!.*==)(?=.*[=]))\b/m';
$str = 'a = 2
if a == 2:
b=3
a+=1
c = (a,b)
def d(x):
return x-1
a2,B_2 = (3,4)
(g, [h, i]) = [5,[6,7]]
(?![+])';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);