using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=def.)\w+|\b((?!if)\w*(?!\s*[+])(?!.*==)(?=.*[=]))\b";
string input = @"a = 2
if a == 2:
b=3
a+=1
c = (a,b)
def d(x):
return x-1
a2,B_2 = (3,4)
(g, [h, i]) = [5,[6,7]]
(?![+])";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}