const regex = /(?<=def.)\w+|\b((?!if)\w*(?!\s*[+])(?!.*==)(?=.*[=]))\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=def.)\\w+|\\b((?!if)\\w*(?!\\s*[+])(?!.*==)(?=.*[=]))\\b', 'gm')
const str = `a = 2
if a == 2:
b=3
a+=1
c = (a,b)
def d(x):
return x-1
a2,B_2 = (3,4)
(g, [h, i]) = [5,[6,7]]
(?![+])`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}