import re
regex = re.compile(r"(?<=def.)\w+|\b((?!if)\w*(?!\s*[+])(?!.*==)(?=.*[=]))\b", flags=re.MULTILINE)
test_str = ("a = 2\n"
"if a == 2:\n"
" b=3\n"
" a+=1\n"
"c = (a,b)\n"
"def d(x):\n"
" return x-1\n"
"a2,B_2 = (3,4)\n"
"(g, [h, i]) = [5,[6,7]] \n"
"(?![+])")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")