import Foundation
let pattern = #"(?<=def.)\w+|\b((?!if)\w*(?!\s*[+])(?!.*==)(?=.*[=]))\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
a = 2
if a == 2:
b=3
a+=1
c = (a,b)
def d(x):
return x-1
a2,B_2 = (3,4)
(g, [h, i]) = [5,[6,7]]
(?![+])
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)