import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=def.)\\w+|\\b((?!if)\\w*(?!\\s*[+])(?!.*==)(?=.*[=]))\\b";
final String string = "a = 2\n"
+ "if a == 2:\n"
+ " b=3\n"
+ " a+=1\n"
+ "c = (a,b)\n"
+ "def d(x):\n"
+ " return x-1\n"
+ "a2,B_2 = (3,4)\n"
+ "(g, [h, i]) = [5,[6,7]] \n"
+ "(?![+])";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}