#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<pnum>[\dA-Z]{9}).(?<nat>\w{3})(?<yob>\d{2})(?<mob>\d{2})(?<dob>\d{2}).(?<sex>M|F|<{1})(?<yoe>\d{2})(?<moe>\d{2})(?<doe>\d{2}).(?<prnum>[]\d|<A-Z]{16})"
Local $sString = "XDB0602173ESP9009224M1808052RE20040086234046"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")