import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<pnum>[\\dA-Z]{9}).(?<nat>\\w{3})(?<yob>\\d{2})(?<mob>\\d{2})(?<dob>\\d{2}).(?<sex>M|F|<{1})(?<yoe>\\d{2})(?<moe>\\d{2})(?<doe>\\d{2}).(?<prnum>[]\\d|<A-Z]{16})";
final String string = "XDB0602173ESP9009224M1808052RE20040086234046";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}