re = /(?<pnum>[\dA-Z]{9}).(?<nat>\w{3})(?<yob>\d{2})(?<mob>\d{2})(?<dob>\d{2}).(?<sex>M|F|<{1})(?<yoe>\d{2})(?<moe>\d{2})(?<doe>\d{2}).(?<prnum>[]\d|<A-Z]{16})/
str = 'XDB0602173ESP9009224M1808052RE20040086234046'
# Print the match result
str.match(re) do |match|
puts match.to_s
end